Stanford OpenFlow Forums: FlowMod Switch disconnect - Stanford OpenFlow Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

FlowMod Switch disconnect Rate Topic: -----

#1 User is offline   ericcsonhung 

  • Member
  • PipPip
  • Group: Members
  • Posts: 13
  • Joined: 16-May 13

Posted 01 November 2013 - 09:07 AM

Hi everyone,

I am attempting to redirect traffic using flowmod in Mininet, but after a few accepted flowmods, the switches start disconnecting:

3:02:14.533 [Timer-2] INFO  n.b.core.internal.Controller - Switch liveness timeout detected 10894ms, disconnecting OFSwitchImpl [Socket[addr=/127.0.0.1,port=58623,localport=6633] DPID[00:00:00:00:00:00:00:b7]]
13:02:14.533 [Timer-2] INFO  n.b.core.internal.Controller - Switch disconnected OFSwitchImpl [Socket[addr=/127.0.0.1,port=58623,localport=6633] DPID[00:00:00:00:00:00:00:b7]]


If I try to flow mod again to that switch I just get:
OFSwitchImpl [Socket[unconnected] DPID[00:00:00:00:00:00:00:c2]]
Flow Mod to Switch OFSwitchImpl [Socket[unconnected] DPID[00:00:00:00:00:00:00:c2]] In Port 0 Out Port 3
13:02:15.751 [pool-2-thread-1] INFO  n.b.core.io.internal.OFStream - Detected remote switch hangup java.nio.channels.SocketChannel[closed]


It seems to be similar or related to Flow-mod causes switch to disconnect (no errors).

Some context: Running a k=8 fat-tree (128 hosts) in Mininet, with anything between 128-1152 Iperf udp flows.

Thank you
0

#2 User is offline   David Erickson 

  • Developer
  • Group: Administrators
  • Posts: 653
  • Joined: 28-June 11

Posted 08 November 2013 - 08:44 AM

View Postericcsonhung, on 01 November 2013 - 09:07 AM, said:

Hi everyone,

I am attempting to redirect traffic using flowmod in Mininet, but after a few accepted flowmods, the switches start disconnecting:

3:02:14.533 [Timer-2] INFO  n.b.core.internal.Controller - Switch liveness timeout detected 10894ms, disconnecting OFSwitchImpl [Socket[addr=/127.0.0.1,port=58623,localport=6633] DPID[00:00:00:00:00:00:00:b7]]
13:02:14.533 [Timer-2] INFO  n.b.core.internal.Controller - Switch disconnected OFSwitchImpl [Socket[addr=/127.0.0.1,port=58623,localport=6633] DPID[00:00:00:00:00:00:00:b7]]


If I try to flow mod again to that switch I just get:
OFSwitchImpl [Socket[unconnected] DPID[00:00:00:00:00:00:00:c2]]
Flow Mod to Switch OFSwitchImpl [Socket[unconnected] DPID[00:00:00:00:00:00:00:c2]] In Port 0 Out Port 3
13:02:15.751 [pool-2-thread-1] INFO  n.b.core.io.internal.OFStream - Detected remote switch hangup java.nio.channels.SocketChannel[closed]


It seems to be similar or related to Flow-mod causes switch to disconnect (no errors).

Some context: Running a k=8 fat-tree (128 hosts) in Mininet, with anything between 128-1152 Iperf udp flows.

Thank you


Do the switch logs give you anything?
0

#3 User is offline   ericcsonhung 

  • Member
  • PipPip
  • Group: Members
  • Posts: 13
  • Joined: 16-May 13

Posted 11 November 2013 - 03:14 PM

Hi David,

No the switch logs do not provide me with any information. Also, today I was attempting to do the same experiment but using a k=4 fat-tree, and during the setup (normally during Configuring hosts), I get the switch liveness disconnect.

Thank you
0

#4 User is offline   David Erickson 

  • Developer
  • Group: Administrators
  • Posts: 653
  • Joined: 28-June 11

Posted 11 November 2013 - 03:23 PM

View Postericcsonhung, on 11 November 2013 - 03:14 PM, said:

Hi David,

No the switch logs do not provide me with any information. Also, today I was attempting to do the same experiment but using a k=4 fat-tree, and during the setup (normally during Configuring hosts), I get the switch liveness disconnect.

Thank you


My only suggestions are to use Wireshark and logging in Beacon to ensure the switch is responding to echo requests, and that they are being properly acknowledged within Beacon.
0

#5 User is offline   Fidel Rosell 

  • Member
  • PipPip
  • Group: Members
  • Posts: 11
  • Joined: 05-February 14
  • LocationMiami

Posted 03 December 2014 - 12:10 PM

Hi David. I am just trying to connect my Fat-tree topology in mininet to Beacon but I am getting this error:


Switch disconnected OFSwitchImpl [Socket[[addr=/127.0.0.1,port=37050,localport=6633] DPID[?]]
PLEASE, COULD YOU HELP ME WITH THIS I HAVE A DEADLINE FOR NEXT SATURDAY.

THANK YOU.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users